You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Rumen Damyanov 9326fc2452
Updated StyleCI configuration
2 viikkoa sitten
src Updated StyleCI configuration 2 viikkoa sitten
tests fix code style for unit test 8 kuukautta sitten
.editorconfig cleanup 1 vuosi sitten
.gitattributes add `.gitattributes` 8 kuukautta sitten
.gitignore Added phpunit.xml 7 kuukautta sitten
.gitlab-ci.yml Added support for Laravel 7 2 viikkoa sitten
.styleci.yml Updated StyleCI configuration 2 viikkoa sitten
CHANGELOG-2.7.md updated CHANGELOG 1 vuosi sitten
CHANGELOG-2.8.md updated CHANGELOG 1 vuosi sitten
CHANGELOG-3.0.md support for Laravel 5.7 1 vuosi sitten
CHANGELOG-3.1.md added CHANGELOG-3.1.md 1 vuosi sitten
CHANGELOG-6.0.md #185 Added support for Laravel 6.0 7 kuukautta sitten
CHANGELOG-7.0.md Added support for Laravel 7 2 viikkoa sitten
CONTRIBUTING.md Fixed testing errors 7 kuukautta sitten
LICENSE.md Added support for Laravel 7 2 viikkoa sitten
README.md Added support for Laravel 7 2 viikkoa sitten
composer.json Added support for Laravel 7 2 viikkoa sitten
phpunit.xml Added phpunit.xml 7 kuukautta sitten

README.md

Laravelium Sitemap package

Laravelium Sitemap generator for Laravel.

Notes

  • Dev Branches are for development and are UNSTABLE (use on your own risk)!

Installation

Run the following command and provide the latest stable version (e.g v7.0.*) :

composer require laravelium/sitemap

or add the following to your composer.json file :

For Laravel 7.0

"laravelium/sitemap": "7.0.*"

(development branch)

"laravelium/sitemap": "7.0.x-dev"

For Laravel 6.0

"laravelium/sitemap": "6.0.*"

(development branch)

"laravelium/sitemap": "6.0.x-dev"

For Laravel 5.8

"laravelium/sitemap": "3.1.*"

(development branch)

"laravelium/sitemap": "3.1.x-dev"

For Laravel 5.7

"laravelium/sitemap": "3.0.*"

(development branch)

"laravelium/sitemap": "3.0.x-dev"

For Laravel 5.6

"laravelium/sitemap": "2.8.*"

(development branch)

"laravelium/sitemap": "2.8.x-dev"

For Laravel 5.5

"laravelium/sitemap": "2.7.*"

(development branch)

"laravelium/sitemap": "2.7.x-dev"

Publish needed assets (styles, views, config files) :

php artisan vendor:publish --provider="Laravelium\Sitemap\SitemapServiceProvider"

Note: Composer won’t update them after composer update, you’ll need to do it manually!

Examples

and more in the Wiki.

Contribution guidelines

Before submiting new merge request or creating new issue, please read contribution guidelines.

License

This package is open-sourced software licensed under the MIT license.